Vanilla 4.4 FMDT

6 posts / 0 new
Last post
Offline
Last seen: 5 years 8 months ago
Joined: 02/04/2014 - 15:15
Vanilla 4.4 FMDT
English

Hi,

I got the following error on Ubuntu 12.04.4 LTS 64 bits with Mysql 5.5.35, when as Admin I try to open MySamples/Dashboard/Sales

FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...

I grep/find in the vbox version for mysql jdbc. I got this :

./resources/jdbc/mysql-connector-java-5.1.25-bin.jar
./webapps/FmLoaderWeb/WEB-INF/lib/mysql-connector-java-5.0.0-beta-bin.jar
./webapps/FmUserWeb/WEB-INF/lib/mysql-connector-java-5.0.0-beta-bin.jar
./webapps/FreeDashboardWeb/WEB-INF/lib/mysql-connector-java-5.1.7-bin.jar
./webapps/FreeWebReport/WEB-INF/lib/mysql-connector-java-5.1.7-bin.jar
./webapps/VanillaRuntime/WEB-INF/eclipse/plugins/org.eclipse.birt.report.data.oda.jdbc_4.3.0.v201306041519/drivers/mysql-connector-java-5.1.25-bin.jar
./webapps/VanillaRuntime/WEB-INF/eclipse/plugins/org.eclipse.datatools.enablement.mysql_1.0.3.v201205252211.jar
./webapps/VanillaRuntime/WEB-INF/eclipse/plugins/org.eclipse.datatools.enablement.mysql.dbdefinition_1.0.4.v201109022331.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles/128/1/.cp/libs/mysql-connector-java-5.1.7-bin.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles/130/1/.cp/libs/geotools/gt-jdbc-mysql-8.0.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles/136/1/.cp/libs/jdbc/mysql-connector-java-5.1.7-bin.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/plugins/org.eclipse.birt.report.data.oda.jdbc_4.3.0.v201306041519/drivers/mysql-connector-java-5.1.25-bin.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/plugins/org.eclipse.datatools.enablement.mysql_1.0.3.v201205252211.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/plugins/org.eclipse.datatools.enablement.mysql.dbdefinition_1.0.4.v201109022331.jar

I did the same in my Ubuntu VM :

./resources/jdbc/mysql-connector-java-5.1.25-bin.jar
./webapps/FmLoaderWeb/WEB-INF/lib/mysql-connector-java-5.0.0-beta-bin.jar
./webapps/FmUserWeb/WEB-INF/lib/mysql-connector-java-5.0.0-beta-bin.jar
./webapps/FreeDashboardWeb/WEB-INF/lib/mysql-connector-java-5.1.7-bin.jar
./webapps/FreeWebReport/WEB-INF/lib/mysql-connector-java-5.1.7-bin.jar
./webapps/VanillaRuntime/WEB-INF/eclipse/plugins/org.eclipse.birt.report.data.oda.jdbc_4.3.0.v201306041519/drivers/mysql-connector-java-5.1.25-bin.jar
./webapps/VanillaRuntime/WEB-INF/eclipse/plugins/org.eclipse.datatools.enablement.mysql_1.0.3.v201205252211.jar
./webapps/VanillaRuntime/WEB-INF/eclipse/plugins/org.eclipse.datatools.enablement.mysql.dbdefinition_1.0.4.v201109022331.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles/26/1/.cp/libs/jdbc/mysql-connector-java-5.1.7-bin.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles/304/1/.cp/libs/geotools/gt-jdbc-mysql-8.0.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles/99/1/.cp/libs/mysql-connector-java-5.1.7-bin.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/plugins/org.eclipse.birt.report.data.oda.jdbc_4.3.0.v201306041519/drivers/mysql-connector-java-5.1.25-bin.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/plugins/org.eclipse.datatools.enablement.mysql_1.0.3.v201205252211.jar
./work/Catalina/localhost/VanillaRuntime/eclipse/plugins/org.eclipse.datatools.enablement.mysql.dbdefinition_1.0.4.v201109022331.jar

Except for the path into

./work/Catalina/localhost/VanillaRuntime/eclipse/configuration/org.eclipse.osgi/bundles

I got the same version of jars.

 

What am I missing ?

 

Regards,

 

Sylvain

SVI
Offline
Last seen: 3 years 4 weeks ago
Joined: 09/02/2013 - 10:30

Hi,

Sorry for the late reply, we had some trouble with the website the past few weeks.

About your problem:

"FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it..."

This is just a warning and it should run without problem.

Can you tell me what you see when you launch the dashboard and also can you join me a zip file of the folder logs (it is in [VanillaPlatform]/logs) ?

Best regards,

Sébastien

Offline
Last seen: 5 years 4 months ago
Joined: 03/12/2014 - 22:05

Hi,

I have the same problem. I am trying use the vanilla server for the first time!!

Do you have a solution?

When i go to "http://192.168.137.18:8080/vanilla" and open a report in My Samples (sales), i get this message:
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
ERROR bpm.metadata.birt.oda.runtime - Error when executing query :
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
FMDT : JDBC Driver class com.mysql.jdbc.Driver not found, trying to load it...
ERROR bpm.metadata.birt.oda.runtime - Error when executing query :

And nothing appears in the Parameters!!

Thanks

 

-------------------

Miguel Costa

Offline
Last seen: 2 years 11 months ago
Joined: 06/18/2014 - 17:59

Alright, well, besides having the same JDBC driver issue as the previous two people (which is apparently irrelevant), I have a similar issue trying to bring up the Sample Data "Sales" Dashboard. The log seems to suggest that the SQL syntax isn't correct in a few places, with the following being an example of one of the outputs it has issues with:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '.year_nb AS "timeline_year_nb" from timeline "timeline" order by "timeline_year_' at line 1

I am running Vanilla on Windows 7 Professional, 64-bit, using localhost, with JRE8, MySQL 5.6. I'll admit that installing Vanilla wasn't as straightforward as I had hoped, so I may have made an error in the process. Any help would be appreciated.

Thanks.

Edit: I also found this after looking at the output again. (More of the same:)

ERROR bpm.metadata.birt.oda.runtime - Error when executing query :

SVI
Offline
Last seen: 3 years 4 weeks ago
Joined: 09/02/2013 - 10:30

Hi,

Vanilla need ANSI mode to be enable in Mysql Configuration. Your error may come from this problem.

Can you try to enable it, and then test again ?

If it's still does not work, can you zip me the folder logs at the root of the VanillaPlatform.

Thanks in advance,
Sébastien

Offline
Last seen: 2 years 11 months ago
Joined: 06/18/2014 - 17:59

Heh... Yeah, that was the issue. I had put 'ansi' in the my.ini file of the MySQL Server's data files, but I likely did not properly restart the server. Nonetheless, when I changed the mode in runtime, things started to work again. I really should have checked that sooner...

Thanks.

- Scott Sarsfield